<!DOCTYPE html>
<html lang="en-US" amp=""><head><meta charset="UTF-8"><meta name="viewport" content="width=device-width, initial-scale=1,minimum-scale=1"><meta name="description" content="Grand Opening of Santa’s Village at Queen Kaahumanu Center"><meta name="keywords" content="Grand Opening of Santa’s Village at Queen Kaahumanu Center"><meta property="fb:app_id" content="116013819632"><meta name="generator" content="Site Kit by Google 1.1.1"><title>Grand Opening of Santa’s Village at Queen Kaahumanu Center | Maui Time</title><link rel="preconnect" href="https://cdn.ampproject.org"><link rel="preconnect" href="https://fonts.gstatic.com/" crossorigin=""><link rel="dns-prefetch" href="//fonts.googleapis.com"><link rel="dns-prefetch" href="//s.w.org"><link rel="dns-prefetch" href="//i0.wp.com"><link rel="dns-prefetch" href="//i1.wp.com"><link rel="dns-prefetch" href="//i2.wp.com"><link rel="preload" as="script" href="https://cdn.ampproject.org/v0.js"><script async="" src="https://cdn.ampproject.org/v0.js"></script><script async custom-element="amp-auto-ads" src="https://cdn.ampproject.org/v0/amp-auto-ads-0.1.js">
</script><script async custom-element="amp-ad" src="https://cdn.ampproject.org/v0/amp-ad-0.1.js"></script><script src="https://cdn.ampproject.org/v0/amp-social-share-0.1.js" async="" custom-element="amp-social-share"></script><script src="https://cdn.ampproject.org/v0/amp-facebook-comments-0.1.js" async="" custom-element="amp-facebook-comments"></script><script src="https://cdn.ampproject.org/v0/amp-mustache-0.2.js" async="" custom-template="amp-mustache"></script><script src="https://cdn.ampproject.org/v0/amp-form-0.1.js" async="" custom-element="amp-form"></script><script src="https://cdn.ampproject.org/v0/amp-iframe-0.1.js" async="" custom-element="amp-iframe"></script><script src="https://cdn.ampproject.org/v0/amp-analytics-0.1.js" async="" custom-element="amp-analytics"></script><!-- End Google Tag Manager --><style amp-custom="">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</style><link rel="alternate" type="application/rss+xml" title="Maui Time » Feed" href="https://mauitime.com/feed/"><link rel="alternate" type="application/rss+xml" title="Maui Time » Comments Feed" href="https://mauitime.com/comments/feed/"><link rel="alternate" type="application/rss+xml" title="Maui Time » Grand Opening of Santa’s Village at Queen Kaahumanu Center Comments Feed" href="https://mauitime.com/entertainment/community/grand-opening-of-santas-village-at-queen-kaahumanu-center/feed/"><link rel="canonical" href="https://mauitime.com/entertainment/community/grand-opening-of-santas-village-at-queen-kaahumanu-center/"><link crossorigin="anonymous" rel="stylesheet" id="magazine-pro-fonts-css" href="https://fonts.googleapis.com/css?family=Roboto%3A300%2C400%7CRaleway%3A400%2C500%2C900&amp;ver=3.4.0" type="text/css" media="all"><link rel="https://api.w.org/" href="https://mauitime.com/wp-json/"><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://mauitime.com/xmlrpc.php?rsd"><link rel="alternate" type="application/json+oembed" href="https://mauitime.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fmauitime.com%2Fentertainment%2Fcommunity%2Fgrand-opening-of-santas-village-at-queen-kaahumanu-center%2F"><link rel="alternate" type="text/xml+oembed" href="https://mauitime.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fmauitime.com%2Fentertainment%2Fcommunity%2Fgrand-opening-of-santas-village-at-queen-kaahumanu-center%2F&amp;format=xml"><link rel="pingback" href="https://mauitime.com/xmlrpc.php"><!-- Google Tag Manager --><script type="application/ld+json">{"@context":"http:\/\/schema.org","publisher":{"@type":"Organization","name":"Maui Time","logo":"https:\/\/i2.wp.com\/mauitime.com\/wp-content\/uploads\/2016\/04\/cropped-mt-web-logo-600-x-150-px.png?fit=254%2C60&ssl=1"},"@type":"BlogPosting","mainEntityOfPage":"https:\/\/mauitime.com\/entertainment\/community\/grand-opening-of-santas-village-at-queen-kaahumanu-center\/","headline":"Grand Opening of Santa’s Village at Queen Kaahumanu Center","datePublished":"2019-12-03T02:00:00-10:00","dateModified":"2019-11-29T23:08:34-10:00","author":{"@type":"Person","name":"Alex Mitchell"},"image":"https:\/\/i0.wp.com\/mauitime.com\/wp-content\/uploads\/2019\/11\/Grand-Opening-of-Santa’s-Village-at-Queen-Kaahumanu-Center_photo-courtesy-of-QKC.jpg?fit=1100%2C675&ssl=1"}</script><style amp-boilerplate="">body{-webkit-animation:-amp-start 8s steps(1,end) 0s 1 normal both;-moz-animation:-amp-start 8s steps(1,end) 0s 1 normal both;-ms-animation:-amp-start 8s steps(1,end) 0s 1 normal both;animation:-amp-start 8s steps(1,end) 0s 1 normal both}@-webkit-keyframes -amp-start{from{visibility:hidden}to{visibility:visible}}@-moz-keyframes -amp-start{from{visibility:hidden}to{visibility:visible}}@-ms-keyframes -amp-start{from{visibility:hidden}to{visibility:visible}}@-o-keyframes -amp-start{from{visibility:hidden}to{visibility:visible}}@keyframes -amp-start{from{visibility:hidden}to{visibility:visible}}</style><noscript><style amp-boilerplate="">body{-webkit-animation:none;-moz-animation:none;-ms-animation:none;animation:none}</style></noscript></head><body class="post-template-default single single-post postid-471143 single-format-standard wp-custom-logo wp-embed-responsive header-full-width content-sidebar genesis-breadcrumbs-visible genesis-singular-image-hidden genesis-footer-widgets-visible primary-nav" itemscope itemtype="https://schema.org/WebPage">
<meta name="google-site-verification" content="FjhX6sANH2MqOu7V3Xju1qXXhIbvgXcOOSfIIfIgZN0"><meta name="p:domain_verify" content="75fd5e75e443f96fc494bea35534123d"><meta name="alexaVerifyID" content="asAH0QJIzZx58SjEdaW05Pamcg"><meta name="msvalidate.01" content="8D1FE6A51F7974C608CF85908B79A404"><!-- Quantcast Tag --><!--noscript-->
<div class="amp-wp-93b8ea5">
<amp-anim src="//pixel.quantserve.com/pixel/p-36OSlufkJOurs.gif" height="1" width="1" alt="Quantcast" class="amp-wp-enforced-sizes" layout="intrinsic"><noscript><img src="//pixel.quantserve.com/pixel/p-36OSlufkJOurs.gif" border="0" height="1" width="1" alt="Quantcast"></noscript></amp-anim></div>
<!--/noscript-->
<!-- End Quantcast tag -->


<meta content="googleanalytics"><meta property="og:type" content="article"><meta property="og:title" content="Grand Opening of Santa’s Village at Queen Kaahumanu Center"><meta property="og:url" content="https://mauitime.com/entertainment/community/grand-opening-of-santas-village-at-queen-kaahumanu-center/"><meta property="og:description" content="Check out the Grand Opening of Santa’s Village at Queen Ka‘ahumanu Center on Saturday, December 7th. Ushered by the Baldwin High School Marching Band, Santa will arrive at the Center Court with sty…"><meta property="article:published_time" content="2019-12-03T02:00:00+00:00"><meta property="article:modified_time" content="2019-11-29T23:08:34+00:00"><meta property="og:site_name" content="Maui Time"><meta property="og:image" content="https://i0.wp.com/mauitime.com/wp-content/uploads/2019/11/Grand-Opening-of-Santa’s-Village-at-Queen-Kaahumanu-Center_photo-courtesy-of-QKC.jpg?fit=1100%2C675&amp;ssl=1"><meta property="og:image:width" content="1100"><meta property="og:image:height" content="675"><meta property="og:locale" content="en_US"><meta name="twitter:creator" content="@jenrusso"><meta name="twitter:site" content="@MauiTime"><meta name="twitter:text:title" content="Grand Opening of Santa’s Village at Queen Kaahumanu Center"><meta name="twitter:image" content="https://i0.wp.com/mauitime.com/wp-content/uploads/2019/11/Grand-Opening-of-Santa’s-Village-at-Queen-Kaahumanu-Center_photo-courtesy-of-QKC.jpg?fit=1100%2C675&amp;ssl=1&amp;w=640"><meta name="twitter:card" content="summary_large_image"><meta name="generator" content="AMP Plugin v1.4.1; mode=standard; experiences=website"><link rel="icon" href="https://i0.wp.com/mauitime.com/wp-content/uploads/2015/01/mt-on-white-logo-54aed301v1_site_icon.png?fit=32%2C32&amp;ssl=1" sizes="32x32"><link rel="icon" href="https://i0.wp.com/mauitime.com/wp-content/uploads/2015/01/mt-on-white-logo-54aed301v1_site_icon.png?fit=192%2C192&amp;ssl=1" sizes="192x192"><link rel="apple-touch-icon-precomposed" href="https://i0.wp.com/mauitime.com/wp-content/uploads/2015/01/mt-on-white-logo-54aed301v1_site_icon.png?fit=180%2C180&amp;ssl=1"><meta name="msapplication-TileImage" content="https://i0.wp.com/mauitime.com/wp-content/uploads/2015/01/mt-on-white-logo-54aed301v1_site_icon.png?fit=270%2C270&amp;ssl=1"><div class="site-container"><ul class="genesis-skip-link"><li><a href="#genesis-content" class="screen-reader-shortcut"> Skip to main content</a></li><li><a href="#genesis-sidebar-primary" class="screen-reader-shortcut"> Skip to primary sidebar</a></li><li><a href="#genesis-footer-widgets" class="screen-reader-shortcut"> Skip to footer</a></li></ul><nav class="nav-primary" aria-label="Main" itemscope itemtype="https://schema.org/SiteNavigationElement" id="genesis-nav-primary"><div class="wrap"><ul id="menu-header-menu-2019" class="menu genesis-nav-menu menu-primary"><li id="menu-item-470876" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-470876"><a href="https://mauitime.com/category/news/" itemprop="url"><span itemprop="name">News</span></a>
<ul class="sub-menu"><li id="menu-item-470877" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-470877"><a href="https://mauitime.com/category/news/business/" itemprop="url"><span itemprop="name">Business</span></a></li>
	<li id="menu-item-470878" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-470878"><a href="https://mauitime.com/category/news/community-news/" itemprop="url"><span itemprop="name">Community News</span></a></li>
	<li id="menu-item-470879" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-470879"><a href="https://mauitime.com/category/news/education-news/" itemprop="url"><span itemprop="name">Education</span></a></li>
	<li id="menu-item-470880" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-470880"><a href="https://mauitime.com/category/news/health/" itemprop="url"><span itemprop="name">Health</span></a></li>
	<li id="menu-item-470881" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-470881"><a href="https://mauitime.com/category/news/law-enforcement/" itemprop="url"><span itemprop="name">Law Enforcement</span></a></li>
	<li id="menu-item-470882" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-470882"><a href="https://mauitime.com/category/news/news-of-the-weird/" itemprop="url"><span itemprop="name">News of the Weird</span></a></li>
	<li id="menu-item-470883" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-470883"><a href="https://mauitime.com/category/news/politics/" itemprop="url"><span itemprop="name">Politics</span></a></li>
	<li id="menu-item-470884" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-470884"><a href="https://mauitime.com/category/news/satire/" itemprop="url"><span itemprop="name">Satire</span></a></li>
	<li id="menu-item-470885" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-470885"><a href="https://mauitime.com/category/news/science-and-environment/" itemprop="url"><span itemprop="name">Science and Environment</span></a></li>
	<li id="menu-item-470886" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-470886"><a href="https://mauitime.com/category/news/surf-sports/" itemprop="url"><span itemprop="name">Surf &amp; Sports</span></a></li>
</ul></li>
<li id="menu-item-470894" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-470894"><a href="https://mauitime.com/category/ehbrah/" itemprop="url"><span itemprop="name">Eh Brah</span></a></li>
<li id="menu-item-470887" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-470887"><a href="https://mauitime.com/category/culture/" itemprop="url"><span itemprop="name">Culture</span></a>
<ul class="sub-menu"><li id="menu-item-470888" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-470888"><a href="https://mauitime.com/category/culture/activities/" itemprop="url"><span itemprop="name">Activities</span></a></li>
	<li id="menu-item-470889" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-470889"><a href="https://mauitime.com/category/culture/fashion/" itemprop="url"><span itemprop="name">Fashion</span></a></li>
	<li id="menu-item-470890" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-470890"><a href="https://mauitime.com/category/culture/health-and-wellness/" itemprop="url"><span itemprop="name">Health and Wellness</span></a></li>
	<li id="menu-item-470891" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-470891"><a href="https://mauitime.com/category/culture/history/" itemprop="url"><span itemprop="name">History</span></a></li>
	<li id="menu-item-470895" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-470895"><a href="https://mauitime.com/category/maui-horoscope/" itemprop="url"><span itemprop="name">Horoscope</span></a></li>
	<li id="menu-item-470892" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-470892"><a href="https://mauitime.com/category/culture/maui-community/" itemprop="url"><span itemprop="name">Maui Community</span></a></li>
	<li id="menu-item-470893" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-470893"><a href="https://mauitime.com/category/culture/people/" itemprop="url"><span itemprop="name">People</span></a></li>
</ul></li>
<li id="menu-item-470896" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor menu-item-has-children menu-item-470896"><a href="https://mauitime.com/category/entertainment/" itemprop="url"><span itemprop="name">Entertainment</span></a>
<ul class="sub-menu"><li id="menu-item-470933" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-470933"><a href="https://portal.cityspark.com/EventEntry/EventEntry/MauiTime" itemprop="url"><span itemprop="name">Add Your Event</span></a></li>
	<li id="menu-item-470897" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-470897"><a href="https://mauitime.com/category/entertainment/art-scene/" itemprop="url"><span itemprop="name">Art</span></a></li>
	<li id="menu-item-470898" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-470898"><a href="https://mauitime.com/category/entertainment/calendar-entertainment-2/" itemprop="url"><span itemprop="name">Calendar</span></a></li>
	<li id="menu-item-470899" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-470899"><a href="https://mauitime.com/category/entertainment/community/" itemprop="url"><span itemprop="name">Community Events</span></a></li>
	<li id="menu-item-470900" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-470900"><a href="https://mauitime.com/category/entertainment/conservation-events/" itemprop="url"><span itemprop="name">Conservation Events</span></a></li>
	<li id="menu-item-470932" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-470932"><a href="https://mauitime.com/events#!/" itemprop="url"><span itemprop="name">Events</span></a></li>
	<li id="menu-item-470901" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-470901"><a href="https://mauitime.com/category/entertainment/film-critique/" itemprop="url"><span itemprop="name">Film Critique</span></a></li>
	<li id="menu-item-470902" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-470902"><a href="https://mauitime.com/category/entertainment/health-wellness/" itemprop="url"><span itemprop="name">Health and Wellness Events</span></a></li>
	<li id="menu-item-470903" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-470903"><a href="https://mauitime.com/category/entertainment/movies-showtimes/" itemprop="url"><span itemprop="name">Movies &amp; Showtimes</span></a></li>
	<li id="menu-item-470904" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-470904"><a href="https://mauitime.com/category/entertainment/music/" itemprop="url"><span itemprop="name">Music</span></a></li>
	<li id="menu-item-470905" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-470905"><a href="https://mauitime.com/category/entertainment/sports/" itemprop="url"><span itemprop="name">Sports Events</span></a></li>
	<li id="menu-item-470906" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-470906"><a href="https://mauitime.com/category/entertainment/stage/" itemprop="url"><span itemprop="name">Stage</span></a></li>
</ul></li>
<li id="menu-item-470907" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-470907"><a href="https://mauitime.com/category/food-drink/" itemprop="url"><span itemprop="name">Food &amp; Drink</span></a>
<ul class="sub-menu"><li id="menu-item-470908" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-470908"><a href="https://mauitime.com/category/food-drink/maui-food-news/" itemprop="url"><span itemprop="name">Food News</span></a></li>
	<li id="menu-item-470909" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-470909"><a href="https://mauitime.com/category/food-drink/made-on-maui/" itemprop="url"><span itemprop="name">Made on Maui</span></a></li>
	<li id="menu-item-470910" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-470910"><a href="https://mauitime.com/category/food-drink/maui-bars/" itemprop="url"><span itemprop="name">Maui Bars</span></a></li>
	<li id="menu-item-470911" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-470911"><a href="https://mauitime.com/category/food-drink/maui-restaurants/" itemprop="url"><span itemprop="name">Maui Restaurants</span></a></li>
</ul></li>
<li id="menu-item-470930" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-470930"><a href="https://mauitime.com/events" itemprop="url"><span itemprop="name">Events</span></a>
<ul class="sub-menu"><li id="menu-item-470931" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-470931"><a href="https://portal.cityspark.com/EventEntry/EventEntry/MauiTime" itemprop="url"><span itemprop="name">Add Your Event</span></a></li>
</ul></li>
<li id="menu-item-470913" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-470913"><a href="https://mauitime.com/tips/" itemprop="url"><span itemprop="name">How to Tip</span></a></li>
<li id="menu-item-470914" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-470914"><a href="https://mauitime.com/contact-us-at-mauitime/" itemprop="url"><span itemprop="name">About MauiTime</span></a>
<ul class="sub-menu"><li id="menu-item-470915" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-470915"><a href="https://mauitime.com/advertise/" itemprop="url"><span itemprop="name">Advertise</span></a></li>
	<li id="menu-item-470912" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-470912"><a href="http://eepurl.com/gjG4a5" itemprop="url"><span itemprop="name">Subscribe!</span></a></li>
</ul></li>
</ul></div></nav><header class="site-header" itemscope itemtype="https://schema.org/WPHeader"><div class="wrap"><div class="title-area"><a href="https://mauitime.com/" class="custom-logo-link" rel="home"><amp-img noloading="" width="600" height="142" src="https://i2.wp.com/mauitime.com/wp-content/uploads/2016/04/cropped-mt-web-logo-600-x-150-px.png?fit=600%2C142&amp;ssl=1" class="custom-logo amp-wp-enforced-sizes" alt="Maui Time" srcset="https://i2.wp.com/mauitime.com/wp-content/uploads/2016/04/cropped-mt-web-logo-600-x-150-px.png?w=600&amp;ssl=1 600w, https://i2.wp.com/mauitime.com/wp-content/uploads/2016/04/cropped-mt-web-logo-600-x-150-px.png?resize=300%2C71&amp;ssl=1 300w, https://i2.wp.com/mauitime.com/wp-content/uploads/2016/04/cropped-mt-web-logo-600-x-150-px.png?resize=150%2C36&amp;ssl=1 150w, https://i2.wp.com/mauitime.com/wp-content/uploads/2016/04/cropped-mt-web-logo-600-x-150-px.png?resize=560%2C133&amp;ssl=1 560w" layout="intrinsic"><noscript><img width="600" height="142" src="https://i2.wp.com/mauitime.com/wp-content/uploads/2016/04/cropped-mt-web-logo-600-x-150-px.png?fit=600%2C142&amp;ssl=1" class="custom-logo" alt="Maui Time" srcset="https://i2.wp.com/mauitime.com/wp-content/uploads/2016/04/cropped-mt-web-logo-600-x-150-px.png?w=600&amp;ssl=1 600w, https://i2.wp.com/mauitime.com/wp-content/uploads/2016/04/cropped-mt-web-logo-600-x-150-px.png?resize=300%2C71&amp;ssl=1 300w, https://i2.wp.com/mauitime.com/wp-content/uploads/2016/04/cropped-mt-web-logo-600-x-150-px.png?resize=150%2C36&amp;ssl=1 150w, https://i2.wp.com/mauitime.com/wp-content/uploads/2016/04/cropped-mt-web-logo-600-x-150-px.png?resize=560%2C133&amp;ssl=1 560w" sizes="(max-width: 600px) 100vw, 600px"></noscript></amp-img></a><h1 class="site-title" itemprop="headline">Maui Time</h1><h2 class="site-description" itemprop="description">Mauis Best News, Information and Entertainment Site</h2></div></div></header><div class="site-inner"><div class="content-sidebar-wrap"><main class="content" id="genesis-content"><div class="breadcrumb" itemscope itemtype="https://schema.org/BreadcrumbList">You are here: <span class="breadcrumb-link-wrap" itemprop="itemListElement" itemscope itemtype="https://schema.org/ListItem"><a class="breadcrumb-link" href="https://mauitime.com/" itemprop="item"><span class="breadcrumb-link-text-wrap" itemprop="name">Home</span></a><meta itemprop="position" content="1"></span> <span aria-label="breadcrumb separator">/</span> <span class="breadcrumb-link-wrap" itemprop="itemListElement" itemscope itemtype="https://schema.org/ListItem"><a class="breadcrumb-link" href="https://mauitime.com/category/entertainment/" itemprop="item"><span class="breadcrumb-link-text-wrap" itemprop="name">Entertainment</span></a><meta itemprop="position" content="2"></span> <span aria-label="breadcrumb separator">/</span> <span class="breadcrumb-link-wrap" itemprop="itemListElement" itemscope itemtype="https://schema.org/ListItem"><a class="breadcrumb-link" href="https://mauitime.com/category/entertainment/community/" itemprop="item"><span class="breadcrumb-link-text-wrap" itemprop="name">Community Events</span></a><meta itemprop="position" content="3"></span> <span aria-label="breadcrumb separator">/</span> Grand Opening of Santa’s Village at Queen Kaahumanu Center</div><article class="post-471143 post type-post status-publish format-standard has-post-thumbnail category-community tag-baldwin-high-school-marching-band tag-christmas-events-maui tag-grand-opening-of-santas-village-maui tag-maui-community tag-maui-holiday-events tag-maui-shopping-centers tag-pictures-with-santa-on-maui tag-queen-kaahumanu-center entry" itemscope itemtype="https://schema.org/CreativeWork"><header class="entry-header"><h1 class="entry-title" itemprop="headline">Grand Opening of Santa’s Village at Queen Kaahumanu Center</h1>
<p class="entry-meta"><time class="entry-time" itemprop="datePublished" datetime="2019-12-02T16:00:00-10:00">December 2, 2019</time> by <span class="entry-author" itemprop="author" itemscope itemtype="https://schema.org/Person"><a href="https://mauitime.com/author/alexandra-mitchell/" class="entry-author-link" rel="author" itemprop="url"><span class="entry-author-name" itemprop="name">Alex Mitchell</span></a></span> <span class="entry-comments-link"><a href="https://mauitime.com/entertainment/community/grand-opening-of-santas-village-at-queen-kaahumanu-center/#respond"><span class="dsq-postid" data-dsqidentifier="471143 https://mauitime.com/?p=471143">Leave a Comment</span></a></span> </p></header><div class="entry-content" itemprop="text">
<figure class="wp-block-image size-large"><amp-img src="https://i0.wp.com/mauitime.com/wp-content/uploads/2019/11/Grand-Opening-of-Santa%E2%80%99s-Village-at-Queen-Kaahumanu-Center_photo-courtesy-of-QKC.jpg?resize=1024%2C628&amp;ssl=1" alt="" class="wp-image-471131 amp-wp-unknown-size amp-wp-unknown-width amp-wp-unknown-height amp-wp-enforced-sizes" srcset="https://i0.wp.com/mauitime.com/wp-content/uploads/2019/11/Grand-Opening-of-Santa’s-Village-at-Queen-Kaahumanu-Center_photo-courtesy-of-QKC.jpg?resize=1024%2C628&amp;ssl=1 1024w, https://i0.wp.com/mauitime.com/wp-content/uploads/2019/11/Grand-Opening-of-Santa’s-Village-at-Queen-Kaahumanu-Center_photo-courtesy-of-QKC.jpg?resize=300%2C184&amp;ssl=1 300w, https://i0.wp.com/mauitime.com/wp-content/uploads/2019/11/Grand-Opening-of-Santa’s-Village-at-Queen-Kaahumanu-Center_photo-courtesy-of-QKC.jpg?resize=150%2C92&amp;ssl=1 150w, https://i0.wp.com/mauitime.com/wp-content/uploads/2019/11/Grand-Opening-of-Santa’s-Village-at-Queen-Kaahumanu-Center_photo-courtesy-of-QKC.jpg?resize=768%2C471&amp;ssl=1 768w, https://i0.wp.com/mauitime.com/wp-content/uploads/2019/11/Grand-Opening-of-Santa’s-Village-at-Queen-Kaahumanu-Center_photo-courtesy-of-QKC.jpg?resize=560%2C344&amp;ssl=1 560w, https://i0.wp.com/mauitime.com/wp-content/uploads/2019/11/Grand-Opening-of-Santa’s-Village-at-Queen-Kaahumanu-Center_photo-courtesy-of-QKC.jpg?w=1100&amp;ssl=1 1100w" object-fit="contain" width="600" height="400" layout="intrinsic"><noscript><img src="https://i0.wp.com/mauitime.com/wp-content/uploads/2019/11/Grand-Opening-of-Santa%E2%80%99s-Village-at-Queen-Kaahumanu-Center_photo-courtesy-of-QKC.jpg?resize=1024%2C628&amp;ssl=1" alt="" class="wp-image-471131 amp-wp-unknown-size amp-wp-unknown-width amp-wp-unknown-height" srcset="https://i0.wp.com/mauitime.com/wp-content/uploads/2019/11/Grand-Opening-of-Santa’s-Village-at-Queen-Kaahumanu-Center_photo-courtesy-of-QKC.jpg?resize=1024%2C628&amp;ssl=1 1024w, https://i0.wp.com/mauitime.com/wp-content/uploads/2019/11/Grand-Opening-of-Santa’s-Village-at-Queen-Kaahumanu-Center_photo-courtesy-of-QKC.jpg?resize=300%2C184&amp;ssl=1 300w, https://i0.wp.com/mauitime.com/wp-content/uploads/2019/11/Grand-Opening-of-Santa’s-Village-at-Queen-Kaahumanu-Center_photo-courtesy-of-QKC.jpg?resize=150%2C92&amp;ssl=1 150w, https://i0.wp.com/mauitime.com/wp-content/uploads/2019/11/Grand-Opening-of-Santa’s-Village-at-Queen-Kaahumanu-Center_photo-courtesy-of-QKC.jpg?resize=768%2C471&amp;ssl=1 768w, https://i0.wp.com/mauitime.com/wp-content/uploads/2019/11/Grand-Opening-of-Santa’s-Village-at-Queen-Kaahumanu-Center_photo-courtesy-of-QKC.jpg?resize=560%2C344&amp;ssl=1 560w, https://i0.wp.com/mauitime.com/wp-content/uploads/2019/11/Grand-Opening-of-Santa’s-Village-at-Queen-Kaahumanu-Center_photo-courtesy-of-QKC.jpg?w=1100&amp;ssl=1 1100w" sizes="(max-width: 1000px) 100vw, 1000px" width="600" height="400"></noscript></amp-img></figure><p>Check out the Grand Opening of Santa’s Village at Queen Ka‘ahumanu Center on Saturday, December 7th. Ushered by the Baldwin High School Marching Band, Santa will arrive at the Center Court with style and sound. There’ll be Christmas magic, an enchanting candy lane, Mrs. Claus activities for the keiki, a holiday movie, and more. Santa photo opportunities at QKC are available until Tuesday, December 24th. Book advance appointments through guest services. <strong>10am. Queen Ka‘ahumanu Center, (275 W Ka‘ahumanu Ave., Kahului); 808-877-4325; </strong><a href="http://queenkaahumanucenter.com"><strong>queenkaahumanucenter.com</strong></a></p>



<p><em>photo courtesy of QKC</em></p>



<p>For more up to the date events go to <a href="http://mauitime.com/events">mauitime.com/events</a></p>
<div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><amp-social-share type="facebook" data-param-app_id="249643311490"></amp-social-share><amp-social-share type="twitter"></amp-social-share><!-- not supported: reddit --><amp-social-share type="linkedin"></amp-social-share><amp-social-share type="pinterest"></amp-social-share><amp-social-share type="tumblr"></amp-social-share><!-- not supported: email --><!-- not supported: print --></div></div></div><!-- Facebook Comments Plugin for WordPress: http://peadig.com/wordpress-plugins/facebook-comments/ --><h3>Comments</h3><p> comments</p><amp-facebook-comments layout="fixed-height" width="auto" height="400" data-href="https://mauitime.com/entertainment/community/grand-opening-of-santas-village-at-queen-kaahumanu-center/" data-numposts="5" data-colorscheme="light"></amp-facebook-comments><!--<rdf:RDF xmlns:rdf="http://www.w3.org/1999/02/22-rdf-syntax-ns#"
			xmlns:dc="http://purl.org/dc/elements/1.1/"
			xmlns:trackback="http://madskills.com/public/xml/rss/module/trackback/">
		<rdf:Description rdf:about="https://mauitime.com/entertainment/community/grand-opening-of-santas-village-at-queen-kaahumanu-center/"
    dc:identifier="https://mauitime.com/entertainment/community/grand-opening-of-santas-village-at-queen-kaahumanu-center/"
    dc:title="Grand Opening of Santa’s Village at Queen Kaahumanu Center"
    trackback:ping="https://mauitime.com/entertainment/community/grand-opening-of-santas-village-at-queen-kaahumanu-center/trackback/" />
</rdf:RDF>-->
</div><footer class="entry-footer"><p class="entry-meta"><span class="entry-categories">Filed Under: <a href="https://mauitime.com/category/entertainment/community/" rel="category tag">Community Events</a></span> <span class="entry-tags">Tagged With: <a href="https://mauitime.com/tag/baldwin-high-school-marching-band/" rel="tag">Baldwin high school marching band</a>, <a href="https://mauitime.com/tag/christmas-events-maui/" rel="tag">Christmas events maui</a>, <a href="https://mauitime.com/tag/grand-opening-of-santas-village-maui/" rel="tag">Grand Opening of Santa’s Village maui</a>, <a href="https://mauitime.com/tag/maui-community/" rel="tag">Maui Community Happenings</a>, <a href="https://mauitime.com/tag/maui-holiday-events/" rel="tag">maui holiday events</a>, <a href="https://mauitime.com/tag/maui-shopping-centers/" rel="tag">maui shopping centers</a>, <a href="https://mauitime.com/tag/pictures-with-santa-on-maui/" rel="tag">pictures with Santa on maui</a>, <a href="https://mauitime.com/tag/queen-kaahumanu-center/" rel="tag">Queen Kaahumanu Center</a></span></p><div class="after-entry widget-area"><section id="text-12" class="widget widget_text"><div class="widget-wrap">			<div class="textwidget"><ins class="adsbygoogle amp-wp-fa9aecc" data-ad-format="autorelaxed" data-ad-client="ca-pub-3475394183565613" data-ad-slot="9227507241"></ins>
</div>
		</div></section></div></footer></article><div id="disqus_thread">
    </div>

</main><aside class="sidebar sidebar-primary widget-area" role="complementary" aria-label="Primary Sidebar" itemscope itemtype="https://schema.org/WPSideBar" id="genesis-sidebar-primary"><h2 class="genesis-sidebar-title screen-reader-text">Primary Sidebar</h2><section id="custom_html-3" class="widget_text widget widget_custom_html"><div class="widget_text widget-wrap"><div class="textwidget custom-html-widget"><!-- header ad unit --><ins class="adsbygoogle amp-wp-fa9aecc" data-ad-client="ca-pub-3475394183565613" data-ad-slot="6931752976" data-ad-format="auto" data-full-width-responsive="true"></ins>
</div></div></section><section id="text-27" class="widget widget_text"><div class="widget-wrap">			<div class="textwidget">
<div class="gcse-searchbox-only"></div>
</div>
		</div></section><section id="text-24" class="widget widget_text"><div class="widget-wrap">			<div class="textwidget"><div data-cswidget="9339"></div>

</div>
		</div></section><section id="text-25" class="widget widget_text"><div class="widget-wrap">			<div class="textwidget"><p><!-- Begin Mailchimp Signup Form -->
</p><div id="mc_embed_signup">
<form method="post" id="mc-embedded-subscribe-form" name="mc-embedded-subscribe-form" class="validate" target="_blank" novalidate action-xhr="https://mauitime.us4.list-manage.com/subscribe/post?u=d5b592c19767699d74e4c94ec&amp;id=88e890810b&amp;_wp_amp_action_xhr_converted=1">
<div id="mc_embed_signup_scroll">
<h2>Subscribe</h2>
<div class="indicates-required"><span class="asterisk">*</span> indicates required</div>
<div class="mc-field-group">
	<label for="mce-EMAIL">Email Address  <span class="asterisk">*</span><br></label><br><input type="email" value="" name="EMAIL" class="required email" id="mce-EMAIL"></div>
<div class="mc-field-group">
	<label for="mce-FNAME">First Name  <span class="asterisk">*</span><br></label><br><input type="text" value="" name="FNAME" class="required" id="mce-FNAME"></div>
<div class="mc-field-group">
	<label for="mce-LNAME">Last Name  <span class="asterisk">*</span><br></label><br><input type="text" value="" name="LNAME" class="required" id="mce-LNAME"></div>
<div class="mc-field-group">
	<label for="mce-MMERGE5">Zip Code  <span class="asterisk">*</span><br></label><br><input type="text" value="" name="MMERGE5" class="required" id="mce-MMERGE5"></div>
<div class="mc-field-group input-group">
    <strong>My Interests </strong>
<ul><li><input type="checkbox" value="1" name="group[22237][1]" id="mce-group[22237]-22237-0"><label for="mce-group[22237]-22237-0">News</label></li>
<li><input type="checkbox" value="2" name="group[22237][2]" id="mce-group[22237]-22237-1"><label for="mce-group[22237]-22237-1">Entertainment</label></li>
<li><input type="checkbox" value="4" name="group[22237][4]" id="mce-group[22237]-22237-2"><label for="mce-group[22237]-22237-2">Restaurants</label></li>
<li><input type="checkbox" value="8" name="group[22237][8]" id="mce-group[22237]-22237-3"><label for="mce-group[22237]-22237-3">Eh Brah! and other Columns</label></li>
<li><input type="checkbox" value="16" name="group[22237][16]" id="mce-group[22237]-22237-4"><label for="mce-group[22237]-22237-4">Best of Maui</label></li>
<li><input type="checkbox" value="32" name="group[22237][32]" id="mce-group[22237]-22237-5"><label for="mce-group[22237]-22237-5">Weekly Digest</label></li>
<li><input type="checkbox" value="64" name="group[22237][64]" id="mce-group[22237]-22237-6"><label for="mce-group[22237]-22237-6">Daily Digest</label></li>
</ul></div>
<div id="mergeRow-gdpr" class="mergeRow gdpr-mergeRow content__gdprBlock mc-field-group">
<div class="content__gdpr">
        <label>Seal the Deal</label>
<p>Yaaaas! Almost Done. Please check Email to agree that we are going to send you some dope ass emails.</p>
<fieldset class="mc_fieldset gdprRequired mc-field-group" name="interestgroup_field"><label class="checkbox subfield" for="gdpr_8537"><input type="checkbox" id="gdpr_8537" name="gdpr[8537]" value="Y" class="av-checkbox "><span>Email</span> </label><br></fieldset><p>You can unsubscribe anytime you desire via the footer of our emails. We always keep your info safe, and encrypted.</p>
</div>
<div class="content__gdprLegal">
<p>We use Mailchimp as our marketing platform. By clicking below to subscribe, you acknowledge that your information will be transferred to Mailchimp for processing. <a href="https://mailchimp.com/legal/" target="_blank" rel="noopener noreferrer">Learn more about Mailchimp’s privacy practices here.</a></p>
</div>
</div>
<div id="mce-responses" class="clear">
<div class="response amp-wp-cb45893" id="mce-error-response"></div>
<div class="response amp-wp-cb45893" id="mce-success-response"></div>
</div>
<p>    <!-- real people should not fill this in and expect good things - do not remove this or risk form bot signups--></p>
<div aria-hidden="true" class="amp-wp-4bb72de"><input type="text" name="b_d5b592c19767699d74e4c94ec_88e890810b" tabindex="-1" value=""></div>
<div class="clear"><input type="submit" value="Subscribe" name="subscribe" id="mc-embedded-subscribe" class="button"></div>
</div>
<div class="amp-wp-default-form-message" submit-error=""><template type="amp-mustache"><p class="{{#redirecting}}amp-wp-form-redirecting{{/redirecting}}">{{#message}}{{{message}}}{{/message}}{{^message}}Your submission failed. <small>The server responded with {{status_text}} (code {{status_code}}). Please contact the developer of this form processor to improve this message. <a href="https://amp-wp.org/?p=5463" target="_blank">Learn More</a></small>{{/message}}</p></template></div><div class="amp-wp-default-form-message" submit-success=""><template type="amp-mustache"><p class="{{#redirecting}}amp-wp-form-redirecting{{/redirecting}}">{{#message}}{{{message}}}{{/message}}{{^message}}It appears your submission was successful. <small>Even though the server responded OK, it is possible the submission was not processed. Please contact the developer of this form processor to improve this message. <a href="https://amp-wp.org/?p=5463" target="_blank">Learn More</a></small>{{/message}}</p></template></div><div class="amp-wp-default-form-message" submitting=""><template type="amp-mustache"><p>Submitting…</p></template></div></form>
</div>
<p><br><!--End mc_embed_signup--></p>
</div>
		</div></section><section id="media_image-3" class="widget widget_media_image"><div class="widget-wrap"><a href="https://www.roommates.com/?adv_id=397"><amp-img width="300" height="250" src="https://i2.wp.com/mauitime.com/wp-content/uploads/2018/10/Roomates_Webad_300x250_2.jpg?fit=300%2C250&amp;ssl=1" class="image wp-image-452094  attachment-medium size-medium amp-wp-enforced-sizes amp-wp-36746cb" alt="" layout="intrinsic"><noscript><img width="300" height="250" src="https://i2.wp.com/mauitime.com/wp-content/uploads/2018/10/Roomates_Webad_300x250_2.jpg?fit=300%2C250&amp;ssl=1" class="image wp-image-452094  attachment-medium size-medium amp-wp-36746cb" alt=""></noscript></amp-img></a></div></section><section id="custom_html-2" class="widget_text widget widget_custom_html"><div class="widget_text widget-wrap"><div class="textwidget custom-html-widget"><ins class="adsbygoogle amp-wp-fa9aecc" data-ad-format="autorelaxed" data-ad-client="ca-pub-3475394183565613" data-ad-slot="5623730103"></ins>
</div></div></section></aside></div></div><div class="footer-widgets" id="genesis-footer-widgets"><h2 class="genesis-sidebar-title screen-reader-text">Footer</h2><div class="wrap"><div class="widget-area footer-widgets-1 footer-widget-area">		<section id="recent-posts-1" class="widget widget_recent_entries"><div class="widget-wrap">		<h3 class="widgettitle widget-title">Recent</h3>
		<ul><li>
					<a href="https://mauitime.com/entertainment/community/grand-opening-of-santas-village-at-queen-kaahumanu-center/" aria-current="page">Grand Opening of Santa’s Village at Queen Kaahumanu Center</a>
									</li>
											<li>
					<a href="https://mauitime.com/entertainment/music/cherry-poppin-daddies-at-charleys-restaurant-and-saloon/">Cherry Poppin’ Daddies at Charley’s Restaurant and Saloon</a>
									</li>
											<li>
					<a href="https://mauitime.com/entertainment/music/bmi-maui-songwriter-festival-kickoff-party-at-fleetwoods-on-front-street/">BMI Maui Songwriter Festival Kickoff Party at Fleetwood’s on Front Street</a>
									</li>
											<li>
					<a href="https://mauitime.com/entertainment/community/holiday-fair-at-montessori-school-of-maui/">Holiday Fair at Montessori School of Maui</a>
									</li>
											<li>
					<a href="https://mauitime.com/entertainment/music/dj-freshcobar-at-the-dirty-monkey-in-lahaina/">DJ Freshcobar at The Dirty Monkey in Lahaina</a>
									</li>
					</ul></div></section></div><div class="widget-area footer-widgets-3 footer-widget-area"><section id="search-1" class="widget widget_search"><div class="widget-wrap"><h3 class="widgettitle widget-title">Search</h3>
<form class="search-form" method="get" action="https://mauitime.com/" role="search" itemprop="potentialAction" itemscope itemtype="https://schema.org/SearchAction" target="_top"><label class="search-form-label screen-reader-text" for="searchform-1">Search the site ...</label><input class="search-form-input" type="search" name="s" id="searchform-1" placeholder="Search the site ..." itemprop="query-input"><input class="search-form-submit" type="submit" value="Search"><meta content="https://mauitime.com/?s={s}" itemprop="target"></form></div></section></div></div></div><footer class="site-footer" itemscope itemtype="https://schema.org/WPFooter"><div class="wrap"><p>Copyright © 2019 · <a href="http://my.studiopress.com/themes/magazine/">Magazine Pro</a> on <a href="https://www.studiopress.com/">Genesis Framework</a> · <a href="https://wordpress.org/">WordPress</a> · <a href="https://mauitime.com/wp-login.php">Log in</a></p></div></footer></div><!-- Google Tag Manager (noscript) -->
<!--noscript--><amp-iframe src="https://www.googletagmanager.com/ns.html?id=GTM-TB2K9P" height="400" layout="fixed-height" width="auto" sandbox="allow-scripts allow-same-origin" class="amp-wp-b3bfe1b"><span placeholder="" class="amp-wp-iframe-placeholder"></span><noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-TB2K9P" height="0" width="0" class="amp-wp-b3bfe1b"></iframe></noscript></amp-iframe><!--/noscript-->
<!-- End Google Tag Manager (noscript) -->

<amp-auto-ads type="adsense" data-ad-client="ca-pub-3475394183565613"></amp-auto-ads><!--noscript--><amp-img height="1" width="1" alt="" src="https://www.facebook.com/tr?id=1551057895178934&amp;ev=PixelInitialized" class="amp-wp-enforced-sizes amp-wp-6a19fc1" layout="intrinsic"><noscript><img height="1" width="1" alt="" src="https://www.facebook.com/tr?id=1551057895178934&amp;ev=PixelInitialized" class="amp-wp-cb45893"></noscript></amp-img><!--/noscript-->
<!--noscript--><amp-img height="1" width="1" alt="" src="https://www.facebook.com/tr?id=773356476088910&amp;ev=PixelInitialized" class="amp-wp-enforced-sizes amp-wp-6a19fc1" layout="intrinsic"><noscript><img height="1" width="1" alt="" src="https://www.facebook.com/tr?id=773356476088910&amp;ev=PixelInitialized" class="amp-wp-cb45893"></noscript></amp-img><!--/noscript-->

<amp-analytics type="gtag" data-credentials="include"><script type="application/json">
				{"vars":{"gtag_id":"UA-2809789-1","config":{"UA-2809789-1":{"groups":"default"}}}}			</script></amp-analytics><!-- Google Tag Manager added by Site Kit --><amp-analytics config="https://www.googletagmanager.com/amp.json?id=GTM-TB2K9P" data-credentials="include"></amp-analytics><!-- End Google Tag Manager --><amp-analytics id="e6ae2d1a722e" type="googleanalytics"><script type="application/json">{"vars":{"account":"UA-2809789-1"},"triggers":{"trackPageview":{"on":"visible","request":"pageview"}}}</script></amp-analytics><!-- Facebook Comments Plugin for WordPress: http://peadig.com/wordpress-plugins/facebook-comments/ --><div id="fb-root"></div>
<amp-pixel src="https://pixel.wp.com/g.gif?v=ext&amp;j=1%3A7.9.1&amp;blog=82119061&amp;post=471143&amp;tz=-10&amp;srv=mauitime.com&amp;host=mauitime.com&amp;rand=RANDOM&amp;ref=DOCUMENT_REFERRER"></amp-pixel></body></html>